cvsimport
[findutils.git] / debian / rules
blob7e2b239213b6ce54beda0227194ff3e6202ef872
1 #!/usr/bin/make -f
2 # Sample debian.rules file - for GNU Hello (1.3).
3 # Copyright 1994,1995 by Ian Jackson.
4 # I hereby give you perpetual unlimited permission to copy,
5 # modify and relicense this file, provided that you do not remove
6 # my name from the file itself. (I assert my moral right of
7 # paternity under the Copyright, Designs and Patents Act 1988.)
8 # This file may have to be extensively modified
9 # Copyright 1996 by Kevin Dalley
13 CC = gcc
14 CFLAGS = -O2
15 INSTALL_TARGET=install
16 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
17 CFLAGS += -g
18 endif
19 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
20 INSTALL_TARGET = install-strip
21 endif
23 package = findutils
25 build:
26 $(checkdir)
27 ./configure --prefix=/usr --localstatedir=/var/lib/locate \
28 --libexecdir='$${prefix}/lib/locate' \
29 --mandir='$${prefix}/share/man' \
30 --infodir='$${prefix}/share/info'
31 $(MAKE) \
32 CC="$(CC)" CFLAGS="$(CFLAGS)"
33 cd doc ; makeinfo find.texi
34 touch build
36 clean:
37 $(checkdir)
38 -rm -f build
39 -$(MAKE) -i distclean || $(MAKE) -f Makefile.in distclean
40 -rm -rf *~ debian/tmp debian/*~ debian/files*
42 binary-indep: checkroot build
43 $(checkdir)
44 # There are no architecture-independent files to be uploaded
45 # generated by this package. If there were any they would be
46 # made here.
48 binary-arch: checkroot build
49 $(checkdir)
50 -rm -rf debian/tmp
51 install -d debian/tmp debian/tmp/DEBIAN
52 install -d debian/tmp/usr/share/doc/$(package)
53 install -d debian/tmp/usr/bin
54 install -d debian/tmp/usr/lib
55 install -d debian/tmp/usr/lib/locate
56 install -d debian/tmp/etc
57 install -d debian/tmp/etc/cron.daily
58 install -d debian/tmp/var
59 install -d debian/tmp/var/lib
60 install -d debian/tmp/var/lib/locate
61 install debian/postinst debian/prerm debian/preinst debian/tmp/DEBIAN/.
62 install -m 0644 debian/conffiles debian/tmp/DEBIAN/.
63 install debian/cron.find debian/tmp/etc/cron.daily/find
64 install -m 0644 debian/updatedb.conf debian/tmp/etc/updatedb.conf
65 $(MAKE) DESTDIR=`pwd`/debian/tmp \
66 CC="$(CC)" CFLAGS="$(CFLAGS)" \
67 INSTALL_STRIP_PROGRAM="/usr/bin/install -s" \
68 $(INSTALL_TARGET)
69 install -d debian/tmp/usr/share/doc-base
70 install -m 0644 debian/doc-base \
71 debian/tmp/usr/share/doc-base/findutils
72 gzip -9v debian/tmp/usr/share/info/*
73 gzip -9v debian/tmp/usr/share/man/man[15]/*
74 install -m 0644 debian/copyright debian/tmp/usr/share/doc/$(package)/.
75 install -m 0644 debian/changelog \
76 debian/tmp/usr/share/doc/$(package)/changelog.Debian
77 gzip -9v debian/tmp/usr/share/doc/$(package)/changelog.Debian
78 for file in ChangeLog NEWS README TODO; do \
79 install -m 0644 $$file \
80 debian/tmp/usr/share/doc/$(package);\
81 gzip -9v debian/tmp/usr/share/doc/$(package)/$$file;\
82 done
83 ln -s ChangeLog.gz debian/tmp/usr/share/doc/$(package)/changelog.gz
84 install -m 0644 debian/README.debian \
85 debian/tmp/usr/share/doc/$(package)
86 dpkg-shlibdeps -dPre-Depends debian/tmp/usr/bin/find \
87 debian/tmp/usr/bin/locate debian/tmp/usr/bin/xargs
88 dpkg-gencontrol -isp
89 dpkg --build debian/tmp ..
91 define checkdir
92 test -f find/find.c -a -f debian/rules
93 endef
95 # Below here is fairly generic really
97 binary: binary-indep binary-arch
99 source diff:
100 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
102 checkroot:
103 $(checkdir)
104 test 0 = "`id -u`"
106 .PHONY: binary binary-arch binary-indep clean checkroot