ccc66a30b8e0c1a1aa2907ef18990d0dfe5c0a29
[dottout.git] / net-im / emesene / emesene-2.0.9999.ebuild
blobccc66a30b8e0c1a1aa2907ef18990d0dfe5c0a29
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 inherit git eutils
6 EGIT_REPO_URI="http://github.com/emesene/emesene.git"
7 EGIT_PROJECT="emesene"
8 DESCRIPTION="Platform independent MSN Messenger client written in Python+GTK"
9 HOMEPAGE="http://www.emesene.org"
11 SLOT="0"
12 LICENSE="GPL-2"
13 KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
16 DEPEND="
17 >=dev-lang/python-2.4.3
18 >=x11-libs/gtk+-2.8.20
19 >=dev-python/pygtk-2.8.6
22 RDEPEND="${DEPEND}"
24 src_unpack() {
25 git_src_unpack
28 src_install() {
30 cd ${S}
31 dodir /usr/share/emesene2
32 insinto /usr/share/emesene2
33 doins -r ./*
34 dodir /usr/bin
35 exeinto /usr/bin
36 echo -e '#!/bin/sh \n cd /usr/share/emesene2/ \n python emesene.py'>> emesene2-start
37 doexe emesene2-start
39 newicon ${S}/themes/default/logo.png ${PN}.png
40 make_desktop_entry emesene2-start "EmeSeNe 2 (mesinyer)" ${PN}.png
44 pkg_postinst() {
45 ewarn "Remember, this stuff is SVN only code so dont cry when"
46 ewarn "I break you :)."
47 ewarn "If you want to report bugs, go to our forum at http://emesene.org/forums"