merged emesene and emesene2, updated ebuilds
[dottout.git] / net-im / emesene / emesene-9999.ebuild
blob4f9618759d29d07073b094e3fd895d229bda4ade
2 # Copyright 1999-2006 Gentoo Foundation
3 # Distributed under the terms of the GNU General Public License v2
5 ESVN_REPO_URI="https://emesene.svn.sourceforge.net/svnroot/emesene/trunk/emesene"
6 ESVN_PROJECT="emesene"
8 inherit subversion eutils
10 DESCRIPTION="Platform independent MSN Messenger client written in Python+GTK"
11 HOMEPAGE="http://www.emesene.org"
13 SLOT="0"
14 LICENSE="GPL-2"
15 KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
18 DEPEND=">=dev-lang/python-2.4.3
19 >=x11-libs/gtk+-2.8.20
20 >=dev-python/pygtk-2.8.6
21 media-libs/libmimic"
23 RDEPEND="${DEPEND}"
25 pkg_setup() {
26 ewarn "This is a LIVE SVN ebuild."
27 ewarn "That means there are NO promises it will work."
30 src_compile() {
32 python setup.py build
36 src_install() {
37 python setup.py install
38 dodir /usr/share/emesene
39 insinto /usr/share/emesene
40 doins -r ./*
41 dodir /usr/bin
42 dosym /usr/share/emesene/emesene /usr/bin
43 exeinto /usr/share/emesene
44 doexe emesene
45 newicon ${S}/themes/default/icon96.png ${PN}.png
46 make_desktop_entry emesene "EmeSeNe" ${PN}.png
49 pkg_postinst() {
50 ewarn "Remember, this stuff is SVN only code so dont cry when"
51 ewarn "I break you :)."
52 ewarn "If you want to report bugs, go to our forum at http://emesene.org/forums"