added lcd-stuff-0.1.7 and 9999
[dottout.git] / app-misc / lcd-stuff / lcd-stuff-0.1.7.ebuild
blobd5ea4f7d09a9eedddd9bfee1baaf974405795029
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/app-misc/lcd-stuff/lcd-stuff-0.1.6.ebuild,v 1.2 2009/11/09 13:20:57 maekke Exp $
5 EAPI=2
6 inherit eutils
8 DESCRIPTION="lcd-stuff is a client for lcdproc that displays RSS, Weather, MPD and new mail."
9 HOMEPAGE="http://lcd-stuff.berlios.de/"
10 SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
12 KEYWORDS="amd64 x86"
13 SLOT="0"
14 LICENSE="GPL-2" # and GPL-2 only
16 RDEPEND="app-misc/lcdproc
17 net-misc/curl
18 dev-libs/glib
19 imap? ( net-libs/libetpan )
20 mpd? ( >=media-libs/libmpd-0.12.0 )
21 mp3? ( media-libs/taglib )
22 xml? ( net-libs/libnxml )
23 rss? ( net-libs/libmrss net-libs/libnxml )"
24 DEPEND="${DEPEND}
25 dev-util/pkgconfig"
27 IUSE="imap mpd mp3 xml rss"
29 src_configure() {
30 local XMLRSSLIB="$(use_enable rss mrss)"
31 if use rss ; then
32 # If we want rss, we must also have xml
33 XMLRSSLIB="${XMLRSSLIB} --enable-nxml"
34 else
35 XMLRSSLIB="${XMLRSSLIB} $(use_enable xml nxml)"
38 econf \
39 $(use_enable imap libetpan) \
40 $(use_enable mpd libmpd) \
41 $(use_enable mp3 taglib_c) \
42 $XMLRSSLIB \
43 || die "configure failed"
46 src_install() {
47 emake DESTDIR="${D}" install || die "make install failed"
49 insinto /etc
50 doins lcd-stuff.conf
52 newconfd "${FILESDIR}/${PN}.confd" ${PN}
53 newinitd "${FILESDIR}/${PN}-0.1.2-r1.initd" ${PN}
55 dodoc ChangeLog README