06e9c75f0b461f1031fe1f15a290c7a08037840a
[dottout.git] / app-misc / lcd-stuff / lcd-stuff-9999.ebuild
blob06e9c75f0b461f1031fe1f15a290c7a08037840a
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/app-misc/lcd-stuff/lcd-stuff-0.1.6.ebuild,v 1.2 2009/11/09 13:20:57 maekke Exp $
5 EAPI=2
6 inherit eutils git
8 DESCRIPTION="lcd-stuff is a client for lcdproc that displays RSS, Weather, MPD and new mail."
9 HOMEPAGE="http://lcd-stuff.berlios.de/"
10 EGIT_REPO_URI="git://git.berlios.de/lcd-stuff"
11 EGIT_PROJECT="lcd-stuff"
14 KEYWORDS="amd64 x86"
15 SLOT="0"
16 LICENSE="GPL-2" # and GPL-2 only
18 RDEPEND="app-misc/lcdproc
19 net-misc/curl
20 dev-libs/glib
21 imap? ( net-libs/libetpan )
22 mpd? ( >=media-libs/libmpd-0.12.0 )
23 mp3? ( media-libs/taglib )
24 xml? ( net-libs/libnxml )
25 rss? ( net-libs/libmrss net-libs/libnxml )"
26 DEPEND="${DEPEND}
27 dev-util/pkgconfig"
29 IUSE="imap mpd mp3 xml rss"
31 src_configure() {
32 cd "${S}"
33 ./autogen.sh
34 local XMLRSSLIB="$(use_enable rss mrss)"
35 if use rss ; then
36 # If we want rss, we must also have xml
37 XMLRSSLIB="${XMLRSSLIB} --enable-nxml"
38 else
39 XMLRSSLIB="${XMLRSSLIB} $(use_enable xml nxml)"
42 econf \
43 $(use_enable imap libetpan) \
44 $(use_enable mpd libmpd) \
45 $(use_enable mp3 taglib_c) \
46 $XMLRSSLIB \
47 || die "configure failed"
50 src_install() {
51 emake DESTDIR="${D}" install || die "make install failed"
53 insinto /etc
54 doins lcd-stuff.conf
56 newconfd "${FILESDIR}/${PN}.confd" ${PN}
57 newinitd "${FILESDIR}/${PN}-0.1.2-r1.initd" ${PN}
59 dodoc ChangeLog README