Debian package: Add XULRunner 20 compatibility
authorAxel Beckert <abe@deuxchevaux.org>
Thu, 17 Jan 2013 00:42:18 +0000 (17 01:42 +0100)
committerAxel Beckert <abe@deuxchevaux.org>
Thu, 17 Jan 2013 00:43:01 +0000 (17 01:43 +0100)
debian/changelog
debian/conkeror.bin
debian/control

index ed1bf62..bee9221 100644 (file)
@@ -1,8 +1,8 @@
-conkeror (1.0~~pre+git121201-1) UNRELEASED; urgency=low
+conkeror (1.0~~pre+git130117-1) UNRELEASED; urgency=low
 
-  * Add support for xulrunner 18 and 19
+  * Add support for xulrunner 18 to 20
 
- -- Axel Beckert <abe@debian.org>  Thu, 18 Oct 2012 11:17:54 +0200
+ -- Axel Beckert <abe@debian.org>  Thu, 17 Jan 2013 01:42:48 +0100
 
 conkeror (1.0~~pre+git120901-1) experimental; urgency=low
 
index 9d622c1..a78bbc3 100644 (file)
@@ -5,7 +5,7 @@
 # Find an appropriate xulrunner binary
 XULRUNNER=''
 # Due to http://bugs.debian.org/683157 we currently have to skip xulrunner-14.0
-for version in `LC_ALL=C seq 19.0 -1 15.0` `LC_ALL=C seq 13.0 -1 5.0` 2.0 1.9.2 1.9.1; do
+for version in `LC_ALL=C seq 20.0 -1 15.0` `LC_ALL=C seq 13.0 -1 5.0` 2.0 1.9.2 1.9.1; do
     XRTMP=`which xulrunner-$version`
     if [ -n "$XRTMP" -a -x "$XRTMP" ]; then
        XULRUNNER=$XRTMP
index 8c1be98..1341f38 100644 (file)
@@ -12,6 +12,7 @@ Package: conkeror
 Architecture: all
 Depends: ${misc:Depends},
  xulrunner-10.0  |
+ xulrunner-20.0  |
  xulrunner-19.0  |
  xulrunner-18.0  |
  xulrunner-17.0  |