Debian package: Support XULRunner up to 22
authorAxel Beckert <abe@deuxchevaux.org>
Mon, 4 Mar 2013 19:37:46 +0000 (4 20:37 +0100)
committerAxel Beckert <abe@deuxchevaux.org>
Sun, 7 Apr 2013 01:40:09 +0000 (7 03:40 +0200)
Support for newer Xulrunners closes #699239

Also bump package version to today

debian/bin/conkeror
debian/changelog
debian/control

index a78bbc3..7856b52 100644 (file)
@@ -5,7 +5,7 @@
 # Find an appropriate xulrunner binary
 XULRUNNER=''
 # Due to http://bugs.debian.org/683157 we currently have to skip xulrunner-14.0
-for version in `LC_ALL=C seq 20.0 -1 15.0` `LC_ALL=C seq 13.0 -1 5.0` 2.0 1.9.2 1.9.1; do
+for version in `LC_ALL=C seq 22.0 -1 15.0` `LC_ALL=C seq 13.0 -1 5.0` 2.0 1.9.2 1.9.1; do
     XRTMP=`which xulrunner-$version`
     if [ -n "$XRTMP" -a -x "$XRTMP" ]; then
        XULRUNNER=$XRTMP
index c2e1ee9..b1f0a55 100644 (file)
@@ -1,8 +1,8 @@
-conkeror (1.0~~pre+git130117-1) UNRELEASED; urgency=low
+conkeror (1.0~~pre+git130407-1) UNRELEASED; urgency=low
 
   * New upstream snapshot
     - Properly passes CFLAGS, fully enables dpkg build flags
-  * Add support for xulrunner 18 to 20
+  * Add support for xulrunner 18 to 22 (Closes: #699239)
   * Bump debhelper compatibility to 9
     - Remove inclusion of buildflags.mk from debian/rules, no more needed
   * Clean up debian/rules:
@@ -12,7 +12,7 @@ conkeror (1.0~~pre+git130117-1) UNRELEASED; urgency=low
     - Use more debhelper magic, no more manual cp, ln, or mkdir.
     - Finally switch to a dh style debian/rules.
 
- -- Axel Beckert <abe@debian.org>  Thu, 17 Jan 2013 01:42:48 +0100
+ -- Axel Beckert <abe@debian.org>  Sun, 07 Apr 2013 01:11:16 +0200
 
 conkeror (1.0~~pre+git120901-1) experimental; urgency=low
 
index 6b55b8a..cba7d06 100644 (file)
@@ -12,6 +12,8 @@ Package: conkeror
 Architecture: all
 Depends: ${misc:Depends},
  xulrunner-10.0  |
+ xulrunner-22.0  |
+ xulrunner-21.0  |
  xulrunner-20.0  |
  xulrunner-19.0  |
  xulrunner-18.0  |