ext: enable C extension under Ruby 2.0.0
authorEric Wong <normalperson@yhbt.net>
Tue, 6 Nov 2012 02:57:07 +0000 (6 02:57 +0000)
committerEric Wong <normalperson@yhbt.net>
Tue, 6 Nov 2012 02:58:02 +0000 (6 02:58 +0000)
Ruby 2.0.0preview1 is out, and we happen to be compatible
(with some harmless linker/build warnings)

README
ext/clogger_ext/extconf.rb

diff --git a/README b/README
index a560562..50e7e79 100644 (file)
--- a/README
+++ b/README
@@ -24,7 +24,7 @@ is customizable so you can specify exactly which fields to log.
 
 * Pure Ruby version for non-MRI versions of Ruby (or via CLOGGER_PURE=1
   in the environment).  The optional C extension is loaded by default
-  and supported under MRI 1.8.7, 1.9.1, 1.9.2, 1.9.3 and Rubinius.
+  and supported under MRI 1.8.7, 1.9, 2.0 and Rubinius.
 
 == SYNOPSIS
 
index 1a28319..99f7deb 100644 (file)
@@ -2,11 +2,6 @@ begin
   require 'mkmf'
   $CPPFLAGS += " -D_BSD_SOURCE=1 "
 
-  # XXX let me know if this works for you...
-  if ! defined?(RUBY_VERSION) || RUBY_VERSION !~ /\A1\.[89]\./
-    raise "Invalid RUBY_VERSION for C extension"
-  end
-
   have_header('ruby.h') or raise "ruby.h header not found!"
 
   if have_header('fcntl.h')