Tarball tree for barry-0.17.0.tar.bz2
[barry.git] / debian / rules
blob92af35cfc25026a8aa03759bf054a3c6211d71f4
1 #!/usr/bin/make -f
2 # Based on the multi2 sample debian/rules file:
3 # ---
4 # Sample debian/rules that uses debhelper.
5 # This file is public domain software, originally written by Joey Hess.
7 #export DH_VERBOSE=1
8 include /usr/share/cdbs/1/rules/debhelper.mk
9 include /usr/share/cdbs/1/class/autotools.mk
10 #include /usr/share/cdbs/1/rules/simple-patchsys.mk
12 # where sources are
13 DEB_SRCDIR = .
14 # in which directory to build
15 DEB_BUILDDIR = .
16 # in which directory to install the sofware
17 DEB_DESTDIR = $(CURDIR)/debian/tmp
18 #To register a debug library package libfoo-dbg for libfoo (which needs unstripped '.so') in compat mode 4:
19 DEB_DH_STRIP_ARGS := --dbg-package=libbarry0 --dbg-package=libbarry-dev --dbg-package=barry-util --dbg-package=barrybackup-gui
20 #CDBS automatically handles common flags to pass to the configure script,
21 #but it is possible to give some extra parameters :
22 DEB_CONFIGURE_EXTRA_FLAGS := --enable-boost --enable-nls --with-zlib --enable-gui
23 COMMON_CONFIGURE_FLAGS := --prefix=/usr
24 DEB_INSTALL_DOCS_ALL =
26 install/barry-util::
27 # Install udev rules for the barry-util package
28 install -d $(CURDIR)/debian/barry-util/etc/udev/rules.d
29 install -m 0644 \
30 $(DEB_SRCDIR)/udev/10-blackberry.rules \
31 $(DEB_SRCDIR)/udev/99-blackberry-perms.rules \
32 $(CURDIR)/debian/barry-util/etc/udev/rules.d
33 # Install modprobe blacklist file for bcharge, into barry-util package
34 install -d $(CURDIR)/debian/barry-util/etc/modprobe.d
35 install -m 0644 $(DEB_SRCDIR)/modprobe/blacklist-berry_charge.conf $(CURDIR)/debian/barry-util/etc/modprobe.d/blacklist-berry_charge.conf
36 # Install default ppp options and chat scripts
37 install -d $(CURDIR)/debian/barry-util/etc/ppp/peers
38 install -m 0644 \
39 $(DEB_SRCDIR)/ppp/barry-rogers \
40 $(DEB_SRCDIR)/ppp/barry-minimal \
41 $(DEB_SRCDIR)/ppp/barry-verizon \
42 $(DEB_SRCDIR)/ppp/barry-sprint \
43 $(DEB_SRCDIR)/ppp/barry-telus \
44 $(DEB_SRCDIR)/ppp/barry-o2ireland \
45 $(DEB_SRCDIR)/ppp/barry-tmobileus \
46 $(DEB_SRCDIR)/ppp/barry-att_cingular \
47 $(DEB_SRCDIR)/ppp/barry-chinamobile \
48 $(DEB_SRCDIR)/ppp/barry-kpn \
49 $(DEB_SRCDIR)/ppp/barry-orange-spain \
50 $(DEB_SRCDIR)/ppp/barry-optus-au \
51 $(DEB_SRCDIR)/ppp/barry-vodafone-au \
52 $(CURDIR)/debian/barry-util/etc/ppp/peers
53 install -d $(CURDIR)/debian/barry-util/etc/chatscripts
54 install -m 0640 \
55 $(DEB_SRCDIR)/ppp/barry-rogers.chat \
56 $(DEB_SRCDIR)/ppp/barry-minimal.chat \
57 $(DEB_SRCDIR)/ppp/barry-verizon.chat \
58 $(DEB_SRCDIR)/ppp/barry-sprint.chat \
59 $(DEB_SRCDIR)/ppp/barry-telus.chat \
60 $(DEB_SRCDIR)/ppp/barry-o2ireland.chat \
61 $(DEB_SRCDIR)/ppp/barry-tmobileus.chat \
62 $(DEB_SRCDIR)/ppp/barry-att_cingular.chat \
63 $(DEB_SRCDIR)/ppp/barry-chinamobile.chat \
64 $(DEB_SRCDIR)/ppp/barry-kpn.chat \
65 $(DEB_SRCDIR)/ppp/barry-orange-spain.chat \
66 $(DEB_SRCDIR)/ppp/barry-optus-au.chat \
67 $(DEB_SRCDIR)/ppp/barry-vodafone-au.chat \
68 $(CURDIR)/debian/barry-util/etc/chatscripts
69 # Install hal fdi configs
70 install -d $(CURDIR)/debian/barry-util/usr/share/hal/fdi/information/10freedesktop
71 install -d $(CURDIR)/debian/barry-util/usr/share/hal/fdi/policy/10osvendor
72 install -m 0644 $(DEB_SRCDIR)/hal/fdi/information/10freedesktop/10-blackberry.fdi $(CURDIR)/debian/barry-util/usr/share/hal/fdi/information/10freedesktop
73 install -m 0644 $(DEB_SRCDIR)/hal/fdi/policy/10osvendor/19-blackberry-acl.fdi $(CURDIR)/debian/barry-util/usr/share/hal/fdi/policy/10osvendor
74 # Install hal support script
75 install -d $(CURDIR)/debian/barry-util/usr/bin
76 install -m 0755 $(DEB_SRCDIR)/hal/hal-blackberry $(CURDIR)/debian/barry-util/usr/bin
77 # Install bash and zsh completion scripts
78 install -d $(CURDIR)/debian/barry-util/etc/bash_completion.d
79 install -m 0644 \
80 $(DEB_SRCDIR)/bash/bjavaloader \
81 $(DEB_SRCDIR)/bash/btool \
82 $(CURDIR)/debian/barry-util/etc/bash_completion.d
83 # Install examples/ into libbarry-dev
84 install -d $(CURDIR)/debian/libbarry-dev/usr/share/doc/libbarry-dev/examples
85 install -m 0644 $(DEB_SRCDIR)/examples/*.cc \
86 $(CURDIR)/debian/libbarry-dev/usr/share/doc/libbarry-dev/examples
88 install/barrybackup-gui::
89 # Install barry icon
90 install -d $(CURDIR)/debian/barrybackup-gui/usr/share/pixmaps
91 install -m 0644 $(DEB_SRCDIR)/logo/barry_logo_icon.png $(CURDIR)/debian/barrybackup-gui/usr/share/pixmaps
93 post-patches::
94 @rm -f $(CURDIR)/deb_srcdir
95 @ln -s $(DEB_SRCDIR) $(CURDIR)/deb_srcdir
96 @test -x $(DEB_SRCDIR)/configure && echo "allready autoreconf" || (cd $(DEB_SRCDIR) && autoreconf -i)
98 os22-binary:: binary
99 # DEB_SRCDIR can be relative, so change into directory to use pwd.
101 # Note: that the compiler flags below depend on opensync-plugin's
102 # debian/rules having a DESTDIR target of opensync-plugin/debian/tmp
103 (cd $(DEB_SRCDIR) && \
104 export TREE_BUILD_CXXFLAGS="-I`pwd`/opensync-plugin/debian/tmp/usr/include" && \
105 export TREE_BUILD_LDFLAGS="-L`pwd`/opensync-plugin/debian/tmp/usr/lib" && \
106 export PKG_CONFIG_PATH="`pwd`:$(PKG_CONFIG_PATH)" && \
107 export LD_LIBRARY_PATH="`pwd`/opensync-plugin/debian/tmp/usr/lib:$(LD_LIBRARY_PATH)" && \
108 cd opensync-plugin && \
109 debian/rules TREE_BUILD_DIR="`pwd`/.." binary)
111 os22-clean::
112 (cd $(DEB_SRCDIR)/opensync-plugin && debian/rules clean)
114 os4x-binary:: binary
115 # DEB_SRCDIR can be relative, so change into directory to use pwd.
117 # Note: that the compiler flags below depend on opensync-plugin-0.4x's
118 # debian/rules having a DESTDIR target of opensync-plugin-0.4x/debian/tmp
119 (cd $(DEB_SRCDIR) && \
120 export TREE_BUILD_CXXFLAGS="-I`pwd`/opensync-plugin-0.4x/debian/tmp/usr/include" && \
121 export TREE_BUILD_LDFLAGS="-L`pwd`/opensync-plugin-0.4x/debian/tmp/usr/lib" && \
122 export PKG_CONFIG_PATH="`pwd`:$(PKG_CONFIG_PATH)" && \
123 export LD_LIBRARY_PATH="`pwd`/opensync-plugin-0.4x/debian/tmp/usr/lib:$(LD_LIBRARY_PATH)" && \
124 cd opensync-plugin-0.4x && \
125 debian/rules TREE_BUILD_DIR="`pwd`/.." binary)
127 os4x-clean::
128 (cd $(DEB_SRCDIR)/opensync-plugin-0.4x && debian/rules clean)
130 clean::
131 -@rm -f $(CURDIR)/deb_srcdir