COMP: finiteVolume : explicitly add dependency to libOpenFOAM.so
authormattijs <mattijs>
Fri, 11 Jun 2010 16:04:15 +0000 (11 17:04 +0100)
committermattijs <mattijs>
Fri, 11 Jun 2010 16:04:15 +0000 (11 17:04 +0100)
This caused e.g. paraFoam to not be able to load additional libraries.
Something in paraview caused the libOpenFOAM.so not to be known at lower
levels? dlopen limitation?

src/finiteVolume/Make/options

index b8402e2..b910613 100644 (file)
@@ -3,5 +3,6 @@ EXE_INC = \
     -I$(LIB_SRC)/meshTools/lnInclude
 
 LIB_LIBS = \
+    -lOpenFOAM \
     -ltriSurface \
     -lmeshTools