TEST_REQUIRES was added in 6.63_03
authorH.Merijn Brand - Tux <h.m.brand@xs4all.nl>
Wed, 5 Jun 2013 15:36:37 +0000 (5 17:36 +0200)
committerH.Merijn Brand - Tux <h.m.brand@xs4all.nl>
Wed, 5 Jun 2013 15:36:37 +0000 (5 17:36 +0200)
Perl v5.16.3 shipped with 6.63_02, so passing TEST_REQUIRES on an EUMM
that doesn't support it -- thus the prereq gets lost.

Changelog
Makefile.PL
V.pm
t/10_base.t [changed mode: 0755->0644]

index e48bb3e..56e01f8 100644 (file)
--- a/Changelog
+++ b/Changelog
@@ -1,3 +1,6 @@
+0.19   - 05 Jun 2013, H.Merijn Brand
+    - TEST_REQUIRES was added in 6.63_03 (RT#85811)
+
 0.18   - 24 May 2013, H.Merijn Brand
     * Fixed typo in META (Chorny)
     * Support for using uninstalled Test::NoWarnings (RT#82386)
index a243170..1970522 100644 (file)
@@ -17,8 +17,8 @@ my %wm = (
     PREREQ_PM    => { "Config" => 0,                           },
     macro         => { TARFLAGS => "--format=ustar -c -v -f",  },
     );
-$eummv > 6.30 and $wm{LICENSE} = "perl";
-my $section = $eummv > 6.63 ? "TEST_REQUIRES" : "PREREQ_PM";
+$eummv >= 6.31 and $wm{LICENSE} = "perl";
+my $section = $eummv >= 6.64 ? "TEST_REQUIRES" : "PREREQ_PM";
 $wm{$section}{$_} = 0 for qw( Test::More Test::NoWarnings );
 
 my $rv = WriteMakefile (%wm);
diff --git a/V.pm b/V.pm
index fea6857..1dcfebb 100644 (file)
--- a/V.pm
+++ b/V.pm
@@ -8,7 +8,7 @@ use warnings;
 use Config;
 use Exporter;
 use vars qw($VERSION @ISA @EXPORT_OK %EXPORT_TAGS);
-$VERSION     = "0.18";
+$VERSION     = "0.19";
 @ISA         = ("Exporter");
 @EXPORT_OK   = qw( plv2hash summary myconfig signature );
 %EXPORT_TAGS = (
old mode 100755 (executable)
new mode 100644 (file)