add old ebuilds from svn ub0rlay
[ub0rlay.git] / app-crypt / ccid / ccid-1.3.8.ebuild
blobc91a2fecc0766fe92f0ecf4431c9345d5ec476dd
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/app-crypt/ccid/ccid-1.3.5.ebuild,v 1.2 2008/05/11 13:40:40 alonbl Exp $
5 inherit eutils
7 STUPID_NUM="2482"
8 DESCRIPTION="CCID free software driver"
9 HOMEPAGE="http://pcsclite.alioth.debian.org/ccid.html"
10 SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${P}.tar.bz2"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
14 IUSE="twinserial nousb"
15 RDEPEND=">=sys-apps/pcsc-lite-1.3.3
16 >=dev-libs/libusb-0.1.4"
18 src_unpack() {
19 unpack ${A}
20 cd ${S}
21 epatch ${FILESDIR}/defs-0.patch
24 src_compile() {
25 local myconf
27 use nousb && myconf="${myconf} --disable-pcsclite"
29 econf \
30 LEX=: \
31 --docdir="/usr/share/doc/${PF}" \
32 --enable-udev \
33 ${myconf} \
34 $(use_enable twinserial) || die "econf failed"
35 emake || die "emake failed"
38 src_install() {
39 make install DESTDIR="${D}" || die "Cannot install"
40 dodoc README AUTHORS
41 insinto /etc/udev/rules.d
42 newins src/pcscd_ccid.rules 60-pcscd_ccid.rules