Release 1.17.1 -- Bug Fixes I
[siplcs.git] / README
blob982632d9712f74fc9fec36bdef19c484e76956f3
1 Introduction
2 ============
4 pidgin-sipe is a third-party plugin for the Pidgin/Adium/Miranda/Telepathy
5 multi-protocol instant messaging clients/frameworks. It implements the
6 extended version of SIP/SIMPLE used by various products:
8     * Microsoft Office 365
9     * Microsoft Business Productivity Online Suite (BPOS)
10     * Microsoft Lync Server
11     * Microsoft Office Communications Server (OCS 2007/2007 R2)
12     * Microsoft Live Communications Server (LCS 2003/2005)
13     * Reuters Messaging
15 With this plugin you should be able to replace your Microsoft Office
16 Communicator client with Pidgin/Adium/Miranda/Telepathy.
19 Features
20 ========
22 The plugin has support for
24     * Instant Messaging (IM)
25     * Multiparty chat
26     * Enhanced presence
27     * Calendar integration with Exchange 2007/2010
28     * Contact details information - company, phones, web site, etc.
29     * Contact search - [MS-PRES] and [MS-DLX] methods supported
30     * Encrypted file transfer
31     * Call initiation through PBX
32     * NTLMv2, Kerberos & TLS-DSK authentication support
33     * TLS encryption support
34     * Translated to many languages
36 The plugin has backends for
38     * Pidgin/Finch (libpurple)
39     * Adium (libpurple)
40     * Miranda
41     * Telepathy (under development)
43 Advantages over Office Communicator products
44 ============================================
46     * Available on broader range of platforms: Linux, *BSD, Maemo, OSX,
47       commercial UNIX, Windows.
48     * Ability to simultaneously connect to several Office Communicator
49       accounts in addition to public IM network accounts like MSN, AOL,
50       Yahoo. For example one account is in vendor company and another is
51       in client company.
52     * Keeps history of communications in environments without Outlook. For
53       example in companies where Lotus Notes is deployed as a default
54       groupware client instead of Outlook.
55     * Lotus Notes/Domino calendar integration. Unique to SIPE.
56     * Open development model, open source product. License is GPLv2+
59 Support
60 =======
62 The Pidgin project does not support third-party plugins! If you have problems
63 with this plugin then please check out the support forums:
65     http://sourceforge.net/p/sipe/discussion/
67 Bugs should be reported here:
69     https://sourceforge.net/p/sipe/bugs/
72 Localization
73 ============
75 SIPE has already been localized for several languages. You can help to
76 translate SIPE to your native language at Transifex:
78     https://www.transifex.com/projects/p/pidgin-sipe/r/mob/
80 The service offers a convenient web editor and automatic submission to the
81 repository.
84 Installing from a distribution repository
85 =========================================
87 Many Open Source OS distributions have a ready-made package "pidgin-sipe".
88 Before trying to compile it from the source code yourself, you should try
89 to install this package with the standard installation method provided by
90 your OS.
93 Do It Yourself I: compiling against "pidgin" package
94 ====================================================
96 If you already have installed the "pidgin" package from your distribution
97 repository and want compile pidgin-sipe from source code yourself, then you
98 need to install the necessary headers first. Depending on your distribution
99 you'll need to install one of the following packages
101         libpurple-dev
102         libpurple-devel
104 For the compilation you'll need to install a C compiler and some of the
105 following packages
107         libtool
108         intltool
109         libglib2.0-dev
110         libglib2-devel
111         libxml2-dev
112         libxml2-devel
113         libnss3-dev
114         nss-devel
115         mozilla-nss-devel
116         gettext-devel
118 Now you should be able to compile the source code with
120         ./configure --prefix=/usr
121         make
123 If you get errors then you are missing some required package. After
124 successful compilation you can install pidgin-sipe with:
126         su -c "make install"
128 If you get errors from configure or libtool about version conflicts then
129 you need to regenerate the autoconf files. You'll need these additional
130 packages
132         autoconf
133         automake
135 Now you should be able to regenerate the files with
137         autoreconf --verbose --install --force
139 After that go back to the configure step above.
142 Do It Yourself II: compiling against self-compiled pidgin
143 =========================================================
145 If you have compiled pidgin from source code yourself then you'll have to
146 specify the correct installation path in configure. Usually pidgin is
147 installed in /usr/local so the following command should work
149         ./configure --prefix=/usr/local
151 The rest of the steps are the same as in the previous section.