make methods that should be private, private
[ruby_posix_mq.git] / posix_mq.gemspec
blob2523328bada29dbd33be95df36687555ab0c20bd
1 # -*- encoding: binary -*-
2 ENV["VERSION"] or abort "VERSION= must be specified"
3 manifest = File.readlines('.manifest').map! { |x| x.chomp! }
4 require 'wrongdoc'
5 extend Wrongdoc::Gemspec
6 name, summary, title = readme_metadata
8 Gem::Specification.new do |s|
9   s.name = %q{posix_mq}
10   s.version = ENV["VERSION"].dup
11   s.authors = ["Ruby POSIX MQ hackers"]
12   s.date = Time.now.utc.strftime('%Y-%m-%d')
13   s.description = readme_description
14   s.email = %q{ruby.posix.mq@librelist.com}
15   s.executables = %w(posix-mq-rb)
16   s.extensions = %w(ext/posix_mq/extconf.rb)
17   s.extra_rdoc_files = extra_rdoc_files(manifest)
18   s.files = manifest
19   s.homepage = Wrongdoc.config[:rdoc_url]
20   s.summary = summary
21   s.rdoc_options = rdoc_options
22   s.rubyforge_project = %q{qrp}
23   s.test_files = manifest.grep(%r{\Atest/test_.*\.rb\z})
24   s.add_development_dependency(%q<wrongdoc>, "~> 1.5")
26   # s.licenses = %w(LGPLv3) # accessor not compatible with older RubyGems
27 end