license: use LGPLv2.1 or later (was LGPL (2.1|3.0)-only)
[raindrops.git] / raindrops.gemspec
blobc5d6e877f6331ad17ea368837bc2d600b8350e0e
1 # -*- encoding: binary -*-
2 ENV["VERSION"] or abort "VERSION= must be specified"
3 manifest = File.readlines('.manifest').map! { |x| x.chomp! }
4 test_files = manifest.grep(%r{\Atest/test_.*\.rb\z})
5 require 'wrongdoc'
6 extend Wrongdoc::Gemspec
7 name, summary, title = readme_metadata
9 Gem::Specification.new do |s|
10   s.name = %q{raindrops}
11   s.version = ENV["VERSION"].dup
13   s.authors = ["raindrops hackers"]
14   s.date = Time.now.utc.strftime('%Y-%m-%d')
15   s.description = readme_description
16   s.email = %q{raindrops@librelist.org}
17   s.extensions = %w(ext/raindrops/extconf.rb)
18   s.extra_rdoc_files = extra_rdoc_files(manifest)
19   s.files = manifest
20   s.homepage = Wrongdoc.config[:rdoc_url]
21   s.summary = summary
22   s.rdoc_options = rdoc_options
23   s.rubyforge_project = %q{rainbows}
24   s.test_files = test_files
25   s.add_development_dependency('aggregate', '~> 0.2')
26   s.add_development_dependency('io-extra', [ '~> 1.2', '>= 1.2.3'])
27   s.add_development_dependency('posix_mq', '~> 2.0')
28   s.add_development_dependency('rack', '~> 1.2')
29   s.add_development_dependency('unicorn', '>= 0.98')
30   s.add_development_dependency('wrongdoc', ['~> 1.6.2', '>= 1.6.2'])
32   s.licenses = %w(LGPLv2.1+)
33 end