Debian: Use pkg-info.mk instead of parsing debian/changelog
[conkeror.git] / debian / rules
blob572f58bbcfbfa1aaac479dfe0b09a288d29a6dc5
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
6 # Generating a xulrunner build id and other strings
7 include /usr/share/dpkg/pkg-info.mk
8 BUILDID := debian@$(DEBIAN_VERSION)_$(SOURCE_DATE_EPOCH)
9 US = $(CURDIR)/debian/tmp/usr/share
10 USC = $(US)/conkeror
12 export DEB_BUILD_MAINT_OPTIONS=hardening=+all
13 DPKG_EXPORT_BUILDFLAGS = 1
14 include /usr/share/dpkg/buildflags.mk
15 export CFLAGS+=$(LDFLAGS)
18 dh $@
20 override_dh_auto_install:
21 dh_auto_install -- PREFIX=/usr
22 rm -f $(US)/doc/conkeror/COPYING $(USC)/Info.plist
24 # Add generated Build ID and Debian version to version output
25 sed -e 's/BuildID=git/BuildID=${BUILDID}/;s/^Version=\(.*\)$$/Version=\1 (Debian-${DEBIAN_VERSION})/' \
26 -i $(USC)/application.ini