Debian package: Mention changed CFLAGS handling in debian/changelog
[conkeror.git] / debian / rules
blob738fe242689611942508a36fa13beb7732417c74
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
6 # Generating a xulrunner build id and other strings
7 DEBIAN_VERSION := $(shell echo -n `head -1 debian/changelog | sed -e 's/^.*(\(.*\)).*$$/\\1/'`)
8 BUILDID := $(shell echo -n `whoami`@`hostname`)_$(shell date +%s)
9 USC = $(CURDIR)/debian/conkeror/usr/share/conkeror
12 dh $@
14 override_dh_install-indep:
15 dh_install -i
17 # Add generated Build ID and Debian version to version output
18 sed -e 's/BuildID=git/BuildID=${BUILDID}/;s/^Version=\(.*\)$$/Version=\1 (Debian-${DEBIAN_VERSION})/' \
19 -i $(USC)/application.ini
21 # Use Debian version for M-x version output
22 sed -e 's/Version=\(.*\)/Version=\1 (Debian-${DEBIAN_VERSION})/' \
23 -i $(USC)/components/application.js