Barry debian version 0.18.5-1
[barry.git] / debian / changelog
blob18773905d398e436d1aeb4d8a072cb3ec92ee12e
1 barry (0.18.5-1) unstable; urgency=low
3   * New upstream version 0.18.5
4   * Removed source/options and source/patch-header, using upstream versions
5     instead.
7  -- Chris Frey <cdfrey@foursquare.net>  Sun, 17 Nov 2013 17:29:40 -0500
9 barry (0.18.4-2) unstable; urgency=low
11   * Fixed Break/Replace dependency for barry-backup.mo move
12   * Removed unnecessary subshell in barry-doc packaging
13   * Bumped standards version to 3.9.4 and added default branch to Vcs-Git
14   * Added source/options and source/patch-header
16  -- Chris Frey <cdfrey@foursquare.net>  Tue, 05 Nov 2013 16:12:40 -0500
18 barry (0.18.4-1) unstable; urgency=low
20   * New upstream version 0.18.4
21     - Added barrydesktop.mo and barryosyncwrap.mo files for Desktop
22     - Added ppp chatscripts for eMobile Ireland
23     - Partial Spanish translation, and updated French translations
24     - Fixed potential pppob hang on shutdown
25     - Added pty support to pppob with the -t option
26     - Fixed device renaming bug in Desktop
27     - Added i18n support in various apps, especially the Desktop
28     - Fixed missing BXEXPORT for DataQueue library class
29     - Fixed incorrect handling of vformat line endings when syncing and
30       using MIME formats
31     - Added serial number option (-s) to bidentify
32     - Added Evolution 3.6 support to EvoSources.cc (only useful for builds
33       using OpenSync)
34     - Added Bold 9930 ipmodem timeout fix
35     - Added support for converting "Calendar - All" databases to MIME
36   * New barry-doc package which includes the html user docs (Closes: #582190)
37     This adds new php5-cli build dependency.
38   * Moved barry-backup.mo from barry-util package to barrybackup-gui
40  -- Chris Frey <cdfrey@foursquare.net>  Fri, 04 Apr 2013 14:20:40 -0400
42 barry (0.18.3-6) unstable; urgency=low
44   * Disabled evolution dependency in Desktop build, for upcoming
45     evolution 3.8 in sid. (Closes: #722032)
47  -- Chris Frey <cdfrey@foursquare.net>  Sun, 08 Sep 2013 15:00:07 -0400
49 barry (0.18.3-5) unstable; urgency=low
51   * Removed dependency on ppp for kfreebsd, since kernel side pppd is not
52     available, and freebsd-ppp is not fully supported yet.  Also changed
53     barrydeskop's ppp Depend into a Recommend, since Barry can technically
54     run without it. (Closes: #678233)
56  -- Chris Frey <cdfrey@foursquare.net>  Fri, 22 Jun 2012 17:56:40 -0400
58 barry (0.18.3-3) unstable; urgency=low
60   * Fixed build-dep order for autopoint (Closes: #676321)
62  -- Chris Frey <cdfrey@foursquare.net>  Wed, 06 Jun 2012 17:08:40 -0400
64 barry (0.18.3-2) unstable; urgency=low
66   [Chris Frey]
67   * New upstream version 0.18.3 (Closes: #582189, #582187, #657076, LP: #500370)
68   * Moved opensync-plugin into its own build
69   * Removed dependency of libbarry-dev on libusb-dev
70   * Removed .la files
71   * Added new PPP chat scripts, including: kpn, telus, optus, vodafone AU,
72     orangeuk, mts
73   * Added new programs: bwatch, btarcmp, bjdwp, balxparse, bio, brawchannel
74   * New udev rules set, and now under /lib/udev/rules.d
75   * Added Bash and Zsh completion scripts
76   * Updated Standards-Version to 3.9.3
77   * Reviewed debhelper(7) manpage changes and updated compat to 7 (2012/03/03)
78   * New logo and icons
79   * Added NLS support
80   * Moved hal-blackberry script to /usr/lib/barry/
81   * Added lintian override for libosyncwrap in the barrydesktop package
82   * Updated debian/rules to allow for building with an external debian/
83     directory.
84   * Install examples and documentation.
85   * Configure --with-zlib and --enable-boost.
86   * Add gettext, autopoint, libsdl-dev, and libxml++2.6-dev to build-deps.
87   * Added support for hardened builds
88   * Use 3.0 (quilt) source format, as per intrigeri's patch
90   [ intrigeri ]
91   * Drop obsolete patch, stop using deprecated simple-patchsys.
92   * Use 3.0 (quilt) source format.
93   * Make barry-util.postinst script use 'set -e' rather than '/bin/sh -e'.
94   * Avoid duplicate short descriptions.
95   * Fix typo in description (Closes: #598878)
96   * Fix syntax of old debian/changelog entry.
97   * Fix section of -dbg packages.
98   * Add Homepage control field.
99   * Link to the correct version of GPL and LGPL.
100   * Revert useless changes to upstream files.
102   [ Martin Owens ]
103   * Add versionned dependency from barry-util and barrybackup-gui on libbarry0.
105  -- Chris Frey <cdfrey@foursquare.net>  Tue, 15 May 2012 01:32:40 -0400
107 barry (0.15-1.2) unstable; urgency=low
109   * Non-maintainer upload.
110   * Install udev rules into /lib/udev/rules.d (Closes: #561243, #622564)
111   * Fix uninstallability on kfreebsd-* by making barry-util depend on udev
112     on Linux only (Closes: #639594)
113   * Install udev rules on Linux only.
115  -- intrigeri <intrigeri+debian@boum.org>  Sun, 16 Oct 2011 20:04:55 +0200
117 barry (0.15-1.1) unstable; urgency=low
119   * Non-maintainer upload
120   * Maintainer most apparently MIA
121   * Remove opensync plugins, closes: #569443, #591990
122     Thanks: Mathias Klose <doko@ubuntu.com>
123   * added missing bjavaloader and bfuse programs, closes: #548317
124     Thanks: Fabrice Coutadeur <fabricesp@ubuntu.com>
125   * Remove .la file (no reverse build dependencies), closes: #621271
127  -- Riku Voipio <riku.voipio@linaro.org>  Tue, 16 Aug 2011 10:54:04 +0300
129 barry (0.15-1ubuntu1) lucid; urgency=low
131   * Merge from debian testing (LP: #426716), remaining changes:
132     - debian/barry-util.preinst:
133       + Remove old rules,path if unmodified
134     - debian/barry-util.postinst:
135       + Otherwise move to new path
136     - debian/control:
137       + Update udev dependency
139  -- Bhavani Shankar <right2bhavi@gmail.com>  Fri, 06 Nov 2009 17:54:31 +0530
141 barry (0.15-1) unstable; urgency=low
143   * New Upstream Version
144     + Adds support for Curve 8900 (Closes: #524677)
145   * Ack NMU. Thanks to Cyril Brulebois for it.
146   * Updated patches:
147      - fix-ftbfs-with-new-boost.diff: deleted, fixed upstream.
148      - fix-ftbfs-with-gcc-4.4.diff: updated
149   * debian/rules:
150     + Install udev files from its new location.
151     + Use .conf for modprobe config files (Closes: #518571)
152   * debian/barry-util.install: do not try to install removed bs11nread util
154  -- Jose Carlos Garcia Sogo <jsogo@debian.org>  Sat, 29 Aug 2009 22:57:03 +0200
156 barry (0.14-2.1ubuntu1) karmic; urgency=low
158   * Merge from debian unstable, remaining changes: LP: #401296
159     - debian/rules:
160       + Install udev rules into /lib/udev/rules.d now
161       + Install modprobe file as blacklist-berry_charge.conf
162     - debian/barry-util.preinst:
163       + Remove old rules,path if unmodified
164     - debian/barry-util.postinst:
165       + Otherwise move to new path
166     - debian/control:
167       + Update udev dependency  
169  -- Bhavani Shankar <right2bhavi@gmail.com>  Sun, 19 Jul 2009 12:21:14 +0530
171 barry (0.14-2.1) unstable; urgency=medium
173   * Non-maintainer upload.
174   * Fix FTBFS with new boost (>= 1.37.0) by using the “-mt” suffix for
175     boost libraries since starting with this version, only this variant
176     is available (Closes: #529722). Add the following patch:
177      - fix-ftbfs-with-new-boost.diff (thanks to Steve M. Robbins)
178   * Fix FTBFS with gcc-4.4 (Closes: #505342):
179      - fix-ftbfs-with-gcc-4.4.diff (thanks to Martin Michlmayr)
180   * debian/rules: Add the simple-patchsys.mk include to get both patches
181     applied.
182   * Set urgency to “medium”, both bugs affect testing too.
183   * Add ${misc:Depends} to all Depends fields.
185  -- Cyril Brulebois <kibi@debian.org>  Sat, 18 Jul 2009 12:54:03 +0200
187 barry (0.14-2ubuntu2) jaunty; urgency=low
189   * debian/rules: install modprobe file as blacklist-berry_charge.conf
190   * debian/barry-util.preinst: Remove old path if unmodified
191   * debian/barry-util.postinst: Otherwise move to new path
193  -- Scott James Remnant <scott@ubuntu.com>  Thu, 05 Mar 2009 20:14:50 +0000
195 barry (0.14-2ubuntu1) jaunty; urgency=low
197   * debian/rules: Install udev rules into /lib/udev/rules.d now
198   * debian/barry-util.preinst: Remove old rules if unmodified
199   * debian/control: Update udev dependency.
201  -- Scott James Remnant <scott@ubuntu.com>  Mon, 12 Jan 2009 18:09:36 +0000
203 barry (0.14-2.1) unstable; urgency=medium
205    * Non-maintainer upload.
206    * Fix FTBFS with new boost (>= 1.37.0) by using the “-mt” suffix for
207      boost libraries since starting with this version, only this variant
208      is available (Closes: #529722). Add the following patch:
209       - fix-ftbfs-with-new-boost.diff (thanks to Steve M. Robbins)
210    * Fix FTBFS with gcc-4.4 (Closes: #505342):
211       - fix-ftbfs-with-gcc-4.4.diff (thanks to Martin Michlmayr)
212    * debian/rules: Add the simple-patchsys.mk include to get both patches
213      applied.
214    * Set urgency to “medium”, both bugs affect testing too.
215    * Add ${misc:Depends} to all Depends fields.
217  -- Cyril Brulebois <kibi@debian.org>  Sat, 18 Jul 2009 12:54:03 +0200
219 barry (0.14-2) unstable; urgency=low
221   * debian/rules: Fix libbarry-dbg name
222   * debian/: some debhelper control files were missing in latest release,
223     making binary packages almost empty. Thanks to Michael Banck for pointing it.
224   * debian/control: change opensync plugin package name to match naming scheme 
225     for other opensync plugins. Thanks to Michael Banck.
226   * debian/compat: force level 4 to make easier building of -dbg package  
228  -- Jose Carlos Garcia Sogo <jsogo@debian.org>  Tue, 21 Oct 2008 23:28:05 +0200
230 barry (0.14-1) unstable; urgency=low
232   * New upstream release.
234  -- Jose Carlos Garcia Sogo <jsogo@debian.org>  Sun, 28 Sep 2008 16:43:58 +0200
236 barry (0.13-1) unstable; urgency=low
238   [ Jose Carlos Garcia Sogo ]
239   * Upload to Debian (Closes: #450504)
240   * debian/copyright:
241     + Add copyright holders
242     + Add LGPL as license for vformat.[c,h] files
243   * debian/control:
244     + Change maintainer
245     + Bump Standards-Version to 3.8.0
246     + Rename libbary to libbary0 to follow policy.
247     + Add a dependency on exact binary:Version for each -dbg and -dev package
248     + libbarry-dev binary depends on libusb-dev
249   * debian/changelog:
250     + Merge different versions in 0.13-* packages in a new 0.13-1 one, so it
251     can be uploaded into Debian
252   * debian/rules: no need to call autotools
253   * barrybackup-gui.menu: use Applications/Mobile Devices menu, as per Policy
254   
255   [ Chris Frey ]
256   * From 0.13-1.1 upstream package
257   * added brecsum
258   * added ppp options and chat scripts
259   * fixed lintian description warnings
261   [ Jason Thomas ]
262   * Makefile.am and opensync-plugin/Makefile: add ACLOCAL_FLAGS for autoreconf
263   * debian/control: add build-depends: libglib2.0-dev
264   * debian/control: change build-depends: libopensync0 to libopensync0-dev 
266  -- Jose Carlos Garcia Sogo <jsogo@debian.org>  Sun, 21 Sep 2008 18:59:37 +0200
268 barry (0.12-1) unstable; urgency=low
270    * version bump
272  -- Chris Frey <cdfrey@foursquare.net>  Fri, 07 Dec 2007 16:25:11 -0500
274 barry (0.11-1) unstable; urgency=low
276    * version bump
278  -- Chris Frey <cdfrey@foursquare.net>  Fri, 30 Nov 2007 22:35:11 -0500
280 barry (0.10-1) unstable; urgency=low
282    * renamed ktrans and translate to bktrans and btranslate
283    * added bidentify
285  -- Chris Frey <cdfrey@foursquare.net>  Fri, 30 Nov 2007 15:49:11 -0500
287 barry (0.9-1) unstable; urgency=low
289    * updated for version 0.9 release
290    * converted build scripts to use cdbs
291    * added opensync plugin package
293  -- Chris Frey <cdfrey@foursquare.net>  Thu, 28 Sep 2007 15:55:11 -0500
295 barry (0.8-1) unstable; urgency=low
297    * updated for version 0.8 release
298    * removed postinst, as the latest stable Debian has a current udev version
299    * split packaging into 4 separate packages: libbarry, libbarry-dev,
300      barry-util, barrybackup-gui
301    * added menu support for barrybackup-gui
303  -- Chris Frey <cdfrey@foursquare.net>  Fri, 11 May 2007 16:38:11 -0500
305 barry (0.6-1) unstable; urgency=low
307    * adapted for Debian Etch.  has a newer version of udev, and plugdev 
308      available.  Also added btool in addition to only bcharge available
310  -- Peter Silva <Peter.A.Silva@gmail.com>  Fri, 06 Apr 2007 00:00:01 -0500
312 barry (0.1-2) unstable; urgency=low
314   * Make this work on ubuntu as well.  Ubuntu has a newer version of udev
315     than Debian stable, and needs different rules.
317  -- Chris Frey <cdfrey@foursquare.net>  Fri, 04 Jan 2007 16:23:01 -0500
319 barry (0.1-1) unstable; urgency=low
321   * Initial Release.
323  -- Chris Frey <cdfrey@foursquare.net>  Fri, 29 Dec 2006 20:34:01 -0500